White screen after setup


#1

I have just started my venture into setting up a server. I followed the instructions and have had lots of problems that I figured out with some help from the general internet, but now I am stuck. When I go to localhost I just get a white screen. The shared folder does have logs being written so I think the permissions are correct.

The error begins with:
Error looking up migrations to perform: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
System.Data.SqlClient.SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

It is very long but it repeats this info a few times. I looked up Named Pipes and enabled it but it didn’t make a difference. I am guessing I didn’t do something with the SQL setup. I’ve uninstalled SQL and reinstalled and am getting the same error. I am using MS SQL Express 2017 on Windows Server 2019 Standard.

Thanks
Kathryn


#2

Hi Kathryn!

This error indicates a problem with the GRA software connecting to your SQL Server.

Is SQL Server running on the same system as the GRA software? I think you’d need it to be in order to use Named Pipes. The connection string would look something like \\.\pipe\sql\query I believe, however it’s been years since I’ve used Named Pipes so I’m a little fuzzy on getting that setup working. I can look into it more if that’s what you need.

The other option is to use TCP/IP to connect. If you constructed a SQL Server connection string similar to the one in the documentation it might be trying to connect via TCP/IP. You might try enabling TCP/IP as a protocol for SQL Server if you haven’t already.


#3

Hi again,

So I tried doing what you suggested and still had problems. However another library reached out and tried to help. He has been using GRA for a few years. We started over with a fresh install from Windows on up. He worked through errors all day today and he knows we he’s doing unlike me. But still we are not successful. He told me to ask what permissions are need for what? We keep getting errors related to permission to create the DB. I know he changed the sp_owner permission and tried a variety of ways to connect.

Thanks for your help

Kathryn


#4

I am so sorry that you are having so much trouble getting this going! :frowning:

We create the database first before doing anything else by accessing SQL Server with a system adminsitrator user. That can be done with a database create script (edit that script first!) or manually by right-clicking on Databases in SQL Server Management Studio and choosing New Database....

When creating the database with GRA version 4.1.1 we assign db_owner membership to the database user:

db_owner

(note that for this photo we’ve already created the SQL Server user with a password under Security -> Logins).