Server 2019 & IIS10


#1

Following the instructions on the GRA Wiki to get the program installed, but it’s not working. I appear to have everything set up correctly, but the website will not load; I keep getting 505 errors. Please advise.


#2

Hi, sorry you’re having difficulties!

A few questions:

  1. Are you using the manual as installation guidance?
  2. Are you using the latest version of the GRA (4.1.1)?
  3. Have you installed the .NET Core 2.2 Runtime & Hosting Bundle?
  4. What step in this process are you on where you’re seeing the errors?

#3
  1. Yes, I am.
  2. Yes.
  3. Yes, version 2.2.3 I believe it is
  4. Trying to launch the site. I have tried using the default site in IIS, as well as creating a new site, but no luck. I just keep getting the 505 errors.

#4

When you see errors in your browser, do you see any errors being logged in the shared directory? Have you tried step 5 on that list to modify the Web.config to write out logging information? Having information from those logs might help indicate what is going on. This seems to me like it might be an issue with IIS and ASP.NET Core - possibly permissions related - but more information would help zero in on it.


#5

I tried editing the web.config file, but no luck. It’s not creating the logs folder like it says it should be. I have write permissions to that folder, so I’m not sure what I’m doing wrong. Can you send me some screen shots of a sample folder directory that shows what it should look like?


#6

Harald, any update on this?


#7

Sorry about the delay in getting back to you, I’d thought I’d replied to this message but I hadn’t.

When you say you have write permissions, do you mean your user or the IUSR_<machinename> user or IIS_IUSRS group? Those are the users which typically would be writing logs. Alternately, permissions can be granted for all users to write files to that directory for a while to at least see what the log says about the issues (in the directory properties select the security tab, click edit, click add, type in ‘everyone’, click ok, then check the ‘modify’ box and click ok). I don’t have a screenshot handy but I can probably produce one if needed.

Also, what version of Windows and SQL Server are you using?


#8

Thanks…I’ll try that and see what happens.

We are using Server 2016 Std and SQL Express 2017


#9

@harald I tried giving everyone permissions to that folder, but I still don’t have a logs folder showing anywhere. I did as IIS reset and restarted the website in IIS, but no luck.

*Update: I repaired the install of the .Net Core Hosting Bundle, and now when I start the website and browse to it, I’m getting this:

HTTP Error 502.5 - ANCM Out-Of-Process Startup Failure

Common causes of this issue:

  • The application process failed to start
  • The application process started but then stopped
  • The application process started but failed to listen on the configured port

Troubleshooting steps:

  • Check the system event log for error messages
  • Enable logging the application process’ stdout messages
  • Attach a debugger to the application process and inspect

For more information visit: https://go.microsoft.com/fwlink/?LinkID=808681


#10

Sorry this is causing you so much trouble.

That error appears in Microsoft’s documentation which is a good sign! Can you try the steps in the Troubleshoot app startup errors section of the Microsoft documentation and see if that’s more fruitful in regards to logs? It looks like some of this has changed since I last updated the GRA documentation so I’m sorry if that’s why the logging hasn’t worked!


#11

Thanks, I’ll look at that. Here are some more logs…do these help at all?

Unhandled Exception: System.FormatException: Could not parse the JSON file. Error on line number ‘4’: ‘“ConnectionStrings”: {
“SqlServer”: “Server=TLIB-SAMREAD\READINGADVENTURE;Database=SRP;user id=srp_owner;password=********;MultipleActiveResultSets=true”’. —> Newtonsoft.Json.JsonReaderException: Bad JSON escape sequence: \R. Path ‘ConnectionStrings.SqlServer’, line 4, position 39.
at Newtonsoft.Json.JsonTextReader.ReadStringIntoBuffer(Char quote)
at Newtonsoft.Json.JsonTextReader.ParseValue()
at Newtonsoft.Json.Linq.JContainer.ReadContentFrom(JsonReader r, JsonLoadSettings settings)
at Newtonsoft.Json.Linq.JContainer.ReadTokenFrom(JsonReader reader, JsonLoadSettings options)
at Newtonsoft.Json.Linq.JObject.Load(JsonReader reader, JsonLoadSettings settings)
at Microsoft.Extensions.Configuration.Json.JsonConfigurationFileParser.ParseStream(Stream input)
at Microsoft.Extensions.Configuration.Json.JsonConfigurationProvider.Load(Stream stream)
— End of inner exception stack trace —
at Microsoft.Extensions.Configuration.FileConfigurationProvider.Load(Boolean reload)
at Microsoft.Extensions.Configuration.FileConfigurationProvider.Load()
at Microsoft.Extensions.Configuration.ConfigurationRoot…ctor(IList`1 providers)
at Microsoft.Extensions.Configuration.ConfigurationBuilder.Build()
at Microsoft.AspNetCore.Hosting.WebHostBuilder.BuildCommonServices(AggregateException& hostingStartupErrors)
at Microsoft.AspNetCore.Hosting.WebHostBuilder.Build()
at GRA.Web.Program.Main(String[] args) in /app/src/GRA.Web/Program.cs:line 18

Unhandled Exception: System.FormatException: Could not parse the JSON file. Error on line number ‘4’: ‘“ConnectionStrings”: {
“SqlServer”: “Server=TLIB-SAMREAD\READINGADVENTURE;Database=SRP;user id=srp_owner;password=********;MultipleActiveResultSets=true”’. —> Newtonsoft.Json.JsonReaderException: Bad JSON escape sequence: \R. Path ‘ConnectionStrings.SqlServer’, line 4, position 39.
at Newtonsoft.Json.JsonTextReader.ReadStringIntoBuffer(Char quote)
at Newtonsoft.Json.JsonTextReader.ParseValue()
at Newtonsoft.Json.Linq.JContainer.ReadContentFrom(JsonReader r, JsonLoadSettings settings)
at Newtonsoft.Json.Linq.JContainer.ReadTokenFrom(JsonReader reader, JsonLoadSettings options)
at Newtonsoft.Json.Linq.JObject.Load(JsonReader reader, JsonLoadSettings settings)
at Microsoft.Extensions.Configuration.Json.JsonConfigurationFileParser.ParseStream(Stream input)
at Microsoft.Extensions.Configuration.Json.JsonConfigurationProvider.Load(Stream stream)
— End of inner exception stack trace —
at Microsoft.Extensions.Configuration.FileConfigurationProvider.Load(Boolean reload)
at Microsoft.Extensions.Configuration.FileConfigurationProvider.Load()
at Microsoft.Extensions.Configuration.ConfigurationRoot…ctor(IList`1 providers)
at Microsoft.Extensions.Configuration.ConfigurationBuilder.Build()
at Microsoft.AspNetCore.Hosting.WebHostBuilder.BuildCommonServices(AggregateException& hostingStartupErrors)
at Microsoft.AspNetCore.Hosting.WebHostBuilder.Build()
at GRA.Web.Program.Main(String[] args) in /app/src/GRA.Web/Program.cs:line 18


#12

Yes, this does help! It appears that your SQL Server connection string isn’t formatted properly inside the appsettings.json file. Try putting two backslashes before the instance name instead of one (i.e. TLIB-SAMREAD\\READINGADVENTURE as the server and instance name). Be aware that if there are backslashes or double quotes in your password you’ll need to ensure they are escaped properly for JSON.


#13

That worked!!! Thank you so much. I’m working through the rest of the setup now via the manual. I may have some additional questions though…can I keep this thread open for now?


#14

Absolutely, let us know if you have any questoins/concerns/problems! If not this thread, feel free to open another. :slight_smile: