Installed on Windows Server 2012 - Can't get past initial login


#1

I’ve installed a new instance of GRA in our environment of:
Windows Server 2012 R2
SQL Server 2008 R2
IIS 8
I wasn’t able to have the setup screen come up when I tried running release 2.2.
I downloaded and tried with release 2.1.
I was able to connect and run the Setup screen using release 2.1. Looks like it finished okay. I was able to see that the database tables were created in SQL Server Management Studio.
When I try to log in for the first time as sysadmin, I see the following error:

Server Error in ‘/’ Application.
Login failed for user ‘bjonson’.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Login failed for user ‘bjonson’.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:
[omitted stack trace]Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34248

Thanks,
Gregory Testa


#2

Gregory:

I’m sorry that you’re having trouble getting the GRA going.

Have you tried logging in to the Control Room with the default login of sysadmin and the default password of: changeme05!

Also: did you try 2.2.1 or just 2.2? We have a new release (2.2.1) that is a full release of the most recent code available. You might have better luck with it.


#3

I’m up and running! That must have been what I did (I thought I grabbed 2.2.1 but apparently not). Thanks much for your help!
Best Regards,
Gregory
Chesapeake Public Library