GRA v4.0.0-beta1 released


I wanted to let you all know that we’ve released version 4.0.0-beta1 of The Great Reading Adventure!

(Don’t be afraid that it’s called “-beta1”, I just want to get the documentation sorted before we release what we call 4.0 final. This is the exact code we’ve used for our last three reading programs and I can assure you it’s been very stable for us!)

I’m currently working on getting revisions to the manual that will walk through how to install and configure it in addition to importing the avatars from Glitch. This process is a little different due to our moving to .NET Core. If you are technically minded and antsy, here’s a rough how-to:

  • Install the version 1.1.x “Hosting Bundle” from Microsoft’s .NET Core Runtime downloads on your server
  • Download the GRA v4.0.0-beta1 and unzip it in an IIS Web share
  • Modify appsettings.json to set a SQL Server database connection and change the administrator authorization code
  • Fix permissions (the software expects to write to a directory called shared inside the Web directory)

It’s even easier to deploy in a Docker environment.

I’m working on updating the documentation will post here when I have something that’s a little more user-friendly to walk through.

Again, I apologize that it’s taken us so long to get this released. I can promise you we’ve poured our hearts into it!!

GRA v4 and 2017

Thanks, @harald! Looking forward to getting my hands in it. :slight_smile:


@harald and everyone else,

Indeed, thank you for your diligence and hard work. My team and I look forward to using this new version of the GRA.




I’m trying to modify the appsetting.json file.

I use SQLEXPRESS am having trouble matching up the values in v.3 web.config file with v.4 appsettings.json

please help


I have pushed changes which redo a lot of the manual to better explain how to deploy the application now that it works in an ASP.NET Core environment.

You may need to hold down shift and select reload in your browser to see the latest updates to the manual.

@birchard see if the Configuration page helps with the configuration changes, let me know if that’s unclear and you require more assistance and I’ll do what I can!


@harald: Smooth install - thanks for the updated instructions. I’m stuck soooo close to the end now. Literally the last step before gaining access to Mission Control.

Using the instructions here (, I went to /Join/AuthorizationCode/ and supplied our updated GraInitialAuthCode. It was successful and brought me to the registration page which I completed, but once logged in there was no rocket in the nav bar. When I navigate to /MissionControl the page reroutes to /MissionControl/Home/AuthorizationCode and asks for the GraInitialAuthCode but when I enter it the message is “Unable to activate code: You already belong to the role ‘System Administrator’.” I cleared cookies and tried another browser and I still end up in the loop.

Alternatively I tried the ‘Joining with a regular account’ instructions and I end up in the same loop. I always end up stuck on a page asking for the Authorization Code but telling me I’m already the System administrator.

Any other urls I can try to get around this? Thanks.

edit: Per @harald’s eagle eyes, the initial load of site happened twice (which we’ve determined happened because the page was manually refreshed). After deleting the SQL database and recreating it, the system administrator setup went according to the instructions. After accessing Mission Control I finished loading the avatar bundle which also went without a hitch.


My staff hoped to work on our Summer Reading this week. I asked them to wait for v.4

I tried to unzip it in a subdirectory of the old v3 site. I’m not able to configure.

My v3 server is 2008, IIS 7.0. Is this an issue? Because I think I installed 1.1.x HostBun…

Error Code is 0x8007000d / Config Error “The configuration section ‘aspNetCore’ cannot be read because it is missing a section declaration” / Config File \\? \C\inetpub\wwwroot\v4\web.config

Please advise :slight_smile:


@birchard Do you know if it’s 2008 or 2008 R2? It looks like Microsoft recommends 2008 R2 for hosting ASP.NET Core. I’m not sure if it will run in the original 2008 release.

Did you delete the v3 files before unzipping the v4 files in that directory? You might want to ensure that the v3 files are all gone first. Is that Web.config file the v4.0.0-beta1 Web.config file?



Just a note that I’ve posted a thread about the release of v4.0.0-beta2, so if you’re running beta1 you might want to see that thread and upgrade!