Enable Mixed Content on the GRA website using HTTPS


#1

We deployed the GRA website and installed an SSL certificate and everything works great except that some drop down items do not show up. It looks like mixed content isn’t available on this website. Having SSL enabled is a must. Let me know if there is something we can do to get HTTP and HTTPS content to work.

Thanks,

Sean
City of Cedar Park


#2

Sean:

I’m so sorry you’re seeing this problem. It looks like all recent browsers are now blocking mixed-content. A few points on this:

  1. You could do a search and replace on all the external content URLs in the .aspx pages to replace them with https:// versions, which might work (if those content delivery networks support loading the resources via https).

  2. It looks like you can change settings for <outboundRules> in the Web.config file which might handle that URL rewriting for you. I found information on that here: ASP.NET - Fix for HTTPS/SSL Insecure/Mixed Content Warning.

  3. I’ve removed what I believe to be all the external content links in the latest version but I understand your program starts very soon so I’m not sure it’s feasible for you to switch to the latest code - there have been a lot of changes.

Let me know if that helps.


#3

Where do I find where the External content links? Ive looked through all the aspx files and the ascx files and did a search for http and replaced it with https, but I only really saw this link

http://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js


#4

D’oh, I should have mentioned, I think these are the file extensions to search in:

  • .aspx
  • .ascx
  • .Master

I think that will cover it.


#5

Thanks! I edited the .master files with HTTPS and it appears to have fixed the issues.

Sean


#6

Great! I’m so glad that did the job.