Download Requirements


Our IT department is wondering if there are download instructions and/or requirements for downloading the program. Last year there was a document with information. Is there anything like this for the new version?



I believe the document you’re referring to is this Installation document. This document should still be accurate for the latest release. We are working on improving the documentation but don’t have anything published yet.

Let me know if you run into any problems. Thanks!


Actually, I did run into a problem. When I try and open it, I get a message that says:
“Secure Connection Failed: An error occurred during a connection to SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long). The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.”


Hmm. It seems like there’s a problem with GitHub’s Web site. Perhaps try this link and see if that works?


Sorry - Same message :frowning:


When I search for that issue on Google I see people experiencing it using Firefox. Are you using Firefox? Is it the latest version? Is it possible for you to try loading the page in a different browser?

In any event, I will try to get the documentation moved to a better location for you to access it.


I’ve posted the instructions here on the forum, let me know if you can view them.


I can view them - thanks!