Connecting to SQL


#1

I must be doing something wrong. I’ve got a database on Everleap, FireFTP connected and files uploaded, and now I’m trying to connect to the server in SQL Management Studio 2014 and I’m not having any luck. I don’t know if I’m not putting in the right server name or what. I just get an error saying: A network-related or instance-specific error ocurred while establishing a connection to the SQL server. The server was not found or was not accessible…The network path was not found.


#2

Okay, I got to the point where I upload my query. I can’t seem to create logins and users. I get the same error message.


#3

I’m sorry the directions aren’t better on this. I went through this process the other night with Everleap but I haven’t had an opportunity to document it yet.

Notes:

  1. On your site, edit the Web.config file and ensure the line <add key="IgnoreMissingDatabaseGroups" value="true" /> is in your <appSettings> and is not commented out (comments are surrounded by <!-- and -->). By default in the GRA download it is commented out.

  2. You won’t need to use SSMS since Everleap handles creating the database and user assignment through their control panel under Databases -> MS SQL. If you don’t see a database listed, you’ll create one (I recommend making it 200 MB at least—it looks like Everleap’s pricing is the same up to 1 GB so you might want to make it 500 MB or something just in case). When you select Manage on that screen Everleap will tell you what database server to use (something similar to s02.everleap.com), give you the login, and allow you to set the database password.

  3. You’ll use the same login and password for both database users during initial configuration - that’s why you need to have the IgnoreMissingDatabaseGroups enabled in the Web.config file.

  4. Initial setup should then work when you navigate to your Web site (the URL is on the Everleap control panel).

If you have any further issues don’t hesitate to post them, I’m sure we can work through them. Sorry this isn’t well-documented! :anguished:


#4

Thank you! It’s okay, a lot of this is new to me so at least my trial and error is helping me learn in the process. I am now at 7.1 in the manual #12 and I can’t change the Application pool to ASP.NET v4.0 or to anything else for that matter. Do you know why?


#5

This is probably again due to the ‘managed’ nature of the hosting with Everleap. Fortunately their configuration is already set to ASP.NET 4.5 (I know I saw that somewhere in their control panel earlier this week) so you should be good to go on that. If you find your hostname in the Everleap control panel (something like 1234-56789.el-alt.com) you can visit that rather than localhost as those directions indicate.


#6

I’m not getting the GRA set up screen. This is what it’s showing me ( and sorry for all the questions, but I do appreciate the help…I’m so close I can taste it!):


#7

And I’m sorry, when you say “on your site” where exactly do you mean? On Everleap or elsewhere? I can’t seem to find the Web.config file…


#8

You would need to update the Web.config file locally and then use your FTP software to upload it to your hosting on Everleap.

When you uploaded the files to Everleap, did you place them in site/wwwroot? I see there’s a file in my Everleap wwwroot directory called hostingstart.html which you might need to delete, however it seems like my install worked with that file still present.

Do not worry at all about asking questions, that’s why we’re here! :slight_smile:


#9

I did upload them to site/wwwroot. Right now I’m getting a message saying my license is invalid or non-existent so I’m assuming that has something to do with the version of Visual Studio installed. Working on that at the moment. When I try to double click the file on FireFTP I get this message: Failed to save ‘C:\Users\Staff\Documents\The Great Reading Adventure\Web.config’ locally.
: /site/wwwroot/GreatReadingAdventure-3.1.0/Web.config
You do not have the appropriate permissions or directory does not exist.


#10

Okay, every time I try to edit and save the Web.config file it keeps saying access is denied.


#11

Okay, I figured out that part. Edited. Uploaded to FTP…and I’m now getting this:


#12

I think what you want to do here is copy all the files from inside that GreatReadingAdventure-3.1.0 directory on the server into that /site/wwwroot/ directory on the server. Your FTP program should have the ability to do that.

You also shouldn’t need Visual Studio at all to install and run the GRA software - you only need it in order to do software development.


#13

Does that mean with or without the folders?


#14

The files inside that directory should maintain their file and folder structure, they just should be located in the /site/wwwroot location on the server rather than in /site/wwwroot/GreatReadingAdventure-3.1.0/.


#15

I am so very close! I’m trying to configure my email and no matter what I put in there, the test email won’t work. I’ve done the imap for google with the incoming port and the smtp with the outgoing port. The test email keeps failing to go through. But I got your lovely welcome message! :slight_smile:


#16

Hmm, I’m not sure why Email wouldn’t work. I believe @Tammy is set up using Everleap, perhaps she can provide some input.


#17

Sorry, @LibrarianLisAnn & @Harald, I was away for a day & didn’t get to check any messages. My test emails don’t work either, I just moved forward and skipped that part of the setup for now.

As for creating users, if that’s still a problem - I don’t create them at the host, instead I create them with the SMS SQL & they’re created in the Security area of the database.

Visual Studio - I had to install the latest version, and then I don’t get the error message anymore. I never looked or modified the web.config file to uncomment - if I have no problems, maybe I won’t even check that right now.


#18

I didn’t realize you guys were using Visual Studio at all in this process. I was able to get the site deployed and running by uploading the files via FTP and setting up the SQL through their Web Control Panel.

I really need to spend some time putting directions together on this. I’m sorry that I haven’t been able to it up until this point.

I’m troubled by the email issue - you guys can continue working with your installs because we can edit the Web.config later if we have to to get email working but it seems like Everleap is blocking email somehow. I’ll do some more testing and contact their support if I can’t figure it out.


#19

Please do not apologize, I am so grateful that you’ve even made this available to us…for free! I’m not an IT person, but I feel confident learning in the process knowing that I can have full control over my own Summer Reading Program.

Thank you for being so patient and helpful. I’m working on customizing it now! I still was not able to set up the SMTP. My only other question is how do I connect it to a domain name or find the address to send people to?


#20

There are three options here, I think:

  1. Everleap is going to give you a domain but it’s going to be kinda ugly (it’s that ####-#####.el-alt.com one).

  2. You could get someone IT-related in your organization to make a subdomain for you—for example, if your library was mcldaz.org they could assign summer.mcldaz.org to the IP address you see in your Everleap control panel.

  3. You can find a domain registrar that provides free DNS and register whatever domain you want (e.g. maricopacountyreads.org). Nearly any domain registrar provides DNS at this point. You’ll have to go in and set up a DNS A record pointing to the IP address from the Everleap control panel.

Let me know if you have any trouble with this process, I’ve done it a zillion times. :smile: