Authorization Code says invalid regardless of GraInitialAuthCode value


#1

I have successfully created a working test server, but when making a new install on the actual server that will be used I am getting a strange issue. The /join/authorizationcode page asks for the code like usual, but when it is put in, I get an invalid code error. Even if I totally delete and re-paste a freshly downloaded set of the gra installation into wwwroot and set up the changes that will allow for me to get to the authorization code page, I still get the error. Even if I use the default authcode I still get the error. I am not sure what is causing this, but it almost seems like no matter what is put in the text box to submit as the authcode, the input seems to not be able to be read. It is like whether the code is right or not, it will still be invalid because it cannot be read or something. Log files yield nothing except same as if a wrong password was put in so far. I am still looking for differences between test and the actual server.


#2

That does sound really strange.

Do you have two databases configured (test and production) or are you pointing your production code at the test database?

Also, do you have SQL Server Management Studio installed or another way to run SQL queries against your database? You can go take a look in the authorization code database and ensure your authorization code is set up as expected with a query like this:

SELECT * FROM [AuthorizationCodes];

The other thing you might try is:

SELECT '"' + [Code] + '"' FROM [AuthorizationCodes];

Which will just output all the codes in the system but with double quotes around the code, that way you can be sure there are no spaces at the beginning or end of the code (however I feel like we strip leading and trailing spaces off when we validate the code.